Jump to content

Search the Community

Showing results for tags 'boost'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • General Vehicle Forums
    • XR6 Turbo
    • FPV PERFORMANCE INC.
    • GT335 & GS315
    • G6E Turbo
    • UTEopia
    • Territory Turbo
    • Focus XR5 Turbo
    • Mondeo XR5 Turbo
    • Ford Discussion
    • Ford 4.0L N/A Discussion
    • Conversions, transplants and Frankensteins
  • General Forums
    • General Car Talk
    • Off-Topic
    • Multimedia
    • MotorSport
    • Drag and Circuit Racing
    • Photo Gallery
  • Vehicle Technical Forums
    • General Tech
    • Audio/Visual Workshop
    • Interior & Exterior Workshop
    • Exhaust Workshop
    • Electrics Workshop
    • Wheels and Tyres
    • Suspension and Handling
    • Brakes
    • Driveline Workshop
    • Turbo Workshop
    • Intercooler Workshop
    • ECU Workshop
    • Fuel System & Induction Workshop
    • Blow Off Valve Workshop
    • Engine Workshop
    • 300+ Club
    • 400+ Club
    • 500+ Club
    • 600+ Club
    • 700+ Club
  • Auto News & Reviews
    • Ford US News
  • Advertisers Forums
    • Automotive Catalogues and Specials
    • Autotech Engineering
    • Advertiser Q&A / Feedback Forum
  • Cruise & Event Forums
    • Scheduled Events Forum
    • General Discussion
    • Australian Capital Territory
    • New South Wales
    • Northern Territory
    • Queensland
    • South Australia
    • Tasmania
    • Victoria
    • Western Australia
    • New Zealand
  • The Market Forums
    • Classifieds
    • Small Business Directory
    • Group Buys
  • The Site
    • Site Announcements
    • Merchandise Forum
    • Suggestions, Problems or Questions

Blogs

  • CJF077's Blog
  • xr2dy4's Blog
  • xr2dy4's Blog
  • Dag's Video Blog

Product Groups

  • Advertisements
  • DM Packages
  • Merchandise
    • Stickers
    • Key Rings

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


Location


Interests

  1. Ive scored a brand new Aeroflow 7075. 8005-4004 T4 with1.15 rear My concern is its best rpm range and lag. Car was previously stock engine with nizpro springs, high mount with to4z t4 1.06, 4" dump with 2" wastegate pipe through 50mm wastegate, hdi 600x300x75 cooler, 3.5" xforce exhaust, plazmaman top plenum, seimen daka 660cc injectors. T56 manual sedan. Would start building boost at 1100rpm in top gear. 12psi by 1500rpm. No lag issues. Was running it to 6300rpm New built e
  2. Hey people, I have a 2007 MK2BF, everything is stock. I noticed my car lacking power and could hear a boost leak. Inspected all boost pipes, found pipe on the front of the turbo had come off. Re fitted and tightened, and test drove. Can hear turbo spooling but still has air / boost leak. Turned out my waste gate actuator was faulty. I replaced the actuator and test drove again. Now I cant hear or feel the turbo spooling, but it was before I changed the actuator. Anybody have an idea what the issue could be? Another faulty actuator? Bl
  3. I am writing this to let members know about a very common problem that affects the Turbo Falcons. The electronic boost solenoid gets sticky after about 10,000km. I did this maintenance on my car last Saturday night after reading about it on another forum. My car felt sluggish going onto boost. While the car still pulled like a freight train, it did not come onto power like it used to, so I thought I would try out the procedure. The difference was noticeable on the Bathurst Christmas cruise as the boost came on like it used to without the lag that I was experiencing before the maintenance.
  4. Hi there needing some knowledge and advice, I've got a 2003 ford ba xr6 turbo auto. I've owned it for around 2 and a half years now and it's always had problems, biggest one is when you put your foot down and hold boost for more than 3 or for seconds it starts to shudder really bad and go into like a limp or safety mode and wants to conk out, only way to stop it doing it is to feather the accelerator numerous times then goes back to normal. No engine lights come up or anything of that sort. I had the spark plugs and Coils changed when I first got it, changed the wastegate, that fixed it for a
  5. So basiclly what I want to be able to do is pop 3rd gear from a standing start, but obviously id have to sit it on the limiter for a while for the boost to build up and I cant stand that lol it can spin 3rd when moving I just have to floor it... wait for boost to build up and pop the clutch and what do ya no it spins! so I want to know if anyone knows anything about putting 2 steps on xr6t's...like where to get one... how to install etc etc or if there is anything else that's on the market that will allow me to set my revs while my clutch is pushed in then when I let go it reverts back to its
  6. I have a 2008 fg xr6 turbo at the dyno tuners however have come across an issue they or other dyno tuners havent seen before. The car is going to 17psi on the dyno However any more psi over 17 and the car loses communication and dies on the dyno and launches forward we are trying to achieve 20+ psi, has anybody else come across this issue? Any help would be appreciated. Thankyou
  7. I have a 2008 fg xr6 turbo at the dyno tuners however have come across an issue they or other dyno tuners havent seen before. The car is going to 17psi on the dyno However any more psi over 17 and the car loses communication and dies on the dyno and launches forward we are trying to achieve 20+ psi, has anybody else come across this issue? Any help would be appreciated. Thankyou
  8. Turbs6

    Boost leak?

    Hey guy, I have a 07 bf xr6t auto stock apart from hotside piping, cooler and tune from previous owner. I recently replaced the rubber joiner on throttle body with silicone hose that stopped boost leak and revs issue. I now however have what seems like an intermittent boost leak from turbo side. Still holds boost but seems to lag heaps down low and I can hear air gushing out. It will only last about 5-10 minutes after start up and then comes good and drives fine. Turn the car off for 10 minutes then start back up I get same issue again which then goes away within a few minutes. Iv
  9. Hi there needing some knowledge and advice, I've got a 2003 ford ba xr6 turbo auto. I've owned it for around 2 and a half years now and it's always had problems, biggest one is when you put your foot down and hold boost for more than 3 or for seconds it starts to shudder really bad and go into like a limp or safety mode and wants to conk out, only way to stop it doing it is to feather the accelerator numerous times then goes back to normal. No engine lights come up or anything of that sort. I had the spark plugs and Coils changed when I first got it, changed the wastegate, that fixed it for a
  10. Ok I’ve read page after page after page.... heres where it starts.... bought a ba xr6 turbo Automatic and it came with a x3 flash device that has custom tunes, base 4-5 psi - 8psi - 10psi. Car drives great no weird noises or anything of the like. The problem I’m having is to do with a overboost/limiter issue. This is the 10psi tune. Car accelerates great but once it hits the 10psi mark it either goes to 12psi or it hits 9-10 and it’s like a rev limit and the exhaust makes an almost ‘flame’ sound? And the boost gauge flickers up and down 1psi. Mos
  11. Hey Guys, I've recently come across a problem with having no boost. Gauge says I have good VAC but when I put my foot down it hits 0 on the gauge and stays there. When this is happening all that can be heard is an air rushing noise. I was wondering if anyone else has had similar problems? and where the best place to start would be? Cheers
  12. G'day guys, Im relatively new to this forum to which I have also just purchased a FG Mk1 XR6T Ute. I'm wanting to learn how to mod my car and do different things, and work out what aftermarket parts my ute has (which I will ask in the appropriate sections). What I wanted to ask was, has anyone come up with some creative locations in putting different gauges within a ute or sedan (preferably a FG). If anyone has any pics and would like to post them in this thread, that would be greatly appreciated. The only reason I am wanting to put gauges in is the fact the last person who owned the ute has d
  13. Hi there peeps, Recently got me an F6 and I've only just started to open her up and it sits around .65 - .70 bar of boost at WOT. Is this normal? I've tighten up all the hose clamps. She's bone stock only thing I've got on is the Herrod CAI. Could the plugs have a role? Thanks
  14. So my 2003 ba mk1 turbs spools up and pulls well till about 4-4500 grand than feels as if it hits a wall drops boost n barely runs (like an ecotec after its eco boost) starts jumping around an stalling but if I go nutreul and up revs comes good again n stop carrying on (like cammed LS) to my knowledge id say fuel issue starving for it but its pure stock so nothing is under powered at all.... gonna start fuel filter and hope its a cheap and easy fix (like charlie sheen) an praying to lord jesus that's its not the pump cause "ain't nobody got time for that" just curious if anyone
  15. Have a pretty stock BA xr6t, has xr8 pod style filter, hi flow cat and 2 1/2 inch exhaust. I bought a flash tuner with a 11 psi tune on it. Is this too much boost for stock internals? If so could I just regulate the boost down to say 8-9psi with a boost controller? If not what PSI should I ask for in a custom tune? Thanks for the help! Chris H.
  16. Hi guys. Got a BFII turbo ZF 6spd with 140xxx km, running 60lb dekas and an 11 psi tune. All else it stock. Got a dyno run to see how it is all going, and it came back on the low side. 227 at the rears. The readout showed the boost hitting 11psi and instantly dropping in linear fashion until redline where it reads roughly 7psi or thereabouts. For further testing a mate and I hooked up a boost gauge, which affirmed what the dyno run told us. 11psi down to 7psi over the rev range. What we found out furthermore, is on gearshift the boost returns to 11psi and drops again at higher rpm. So if you
  17. ive got a 2005 ba that evertime I put my foot down it will boost but only until 3000rpm then it feels like its not getting enough fuel....... just wondering if anyone could help me out??
  18. Hey Guys, - just interested in all your experiences / comments on the following: I have a 2013 mk2 FG XR6 TURBO UTE with Luxury Pack (Black of course ) Didn't exactly have and cash to spare on it, so have done minimal mods. First thing I did was a Herrod performance airbox. Gain was minimal, most change in the noise. Next thing I did was remove the restrictive ring after the cat. Again minimal gain, no difference in noise. Decided to go for a flash tune, even through I was sure I would never do it until I ran out of warranty - I ended up getting a generic tune from Intune Motorsports in Sydne
  19. Hi all, I have a BF that is discharging the turbo at around 4000rpm under full throttle. This problem started intermittently, but now is permanent. Still good all the way under half to three quarter throttle. I've checked all intake, outlet pipes, clamps, bov, by passed the boost e sensor, changed the (new) actuator, re-flashed too. Thinking maybe it's the waste gate or fuel pump lagging as it is standard. Has anyone experienced this or can think of anything else to check?
  20. Hello, I need some help if anyone cares to give any info on my turbo problem. I have a BA XR6 turbo ute mk2 that has an intercooler, intake pipework, 3.5ëxhaust. I fitted new 60lb deka injectors and loaded my bpracing X3 60lb 11psi tune today (I know using these tunes can be like playing russian roulette and had planned on not driving it until I get it dyno tuned but I just went for a zip down the road).The car idled fine and drove well unti I hit WOT the turbo made an uneven whooshing noise and then made what sounded like a mega blow off valve noise(not metallic), after the noise I could hear
  21. Gday all new member here. bought a saas guage pod and boost guage. no problems with wiring or pressure hose. not sure how to secure guage properly with supplied bracket. any suggestions?
  22. Hey guys.. Started a couple weeks ago, If I put my foot down in any gear and boost it, I.e. from the lights in first gear to 4000rpm, then back off or change to second and keep going, either way soon as I back off, the engine shudders and revs fluctuate quite a bit, the engine almost stalls > I've cleaned out throttle body > air intakes > plugs are still good > always run 98 > let the engine warm up before pushing it > my mechanic gave the car a look over after changing the rear diff bush and said car looks good Any ideas? Anyone have experienced similar issues? Cheers
  23. Hi Guys, Over the last couple months feels like it's lost a bit of power, and recently the boost is leaking somewhere, as when the turbo is spooling up, the boost is no longer smooth, but instead choppy, I.e. cuts in and out Checked the air intakes for the turbo etc and the air hoses and all still looks fine and well attached. Heard it might be the turbo housing? needs to be tightened again or something? Setup: 2003 BA XR6T 125K clicks on it Running 13psi with xcal Monza cooler Flutter BOV Manual T5 Cheers Big Rob Am I on the right track?
  24. hey there abit confused with what mods I need done on the turbo? I understand it has an internal wastegate, what needs to be done to get an external wastegate done? does the turbo need to be bored out for an exhaust? and the actuator whats the go with all 3 im abit confused atm.. looking at a 4inch dump to a 3inch system x force and love the sound of external gate? please open to suggestions and help!
  25. G'day everyone I have recently traded my 09 FG F6 manual for a 11 FG XR6T auto ute and was wondering if any could tell me if the XR will run the boost and oil temp gauges if I performed a dash conversion any experience?? Cheers in advance!!
×
×
  • Create New...