Jump to content

Greendaddy

New Member
  • Content Count

    14
  • Joined

  • Last visited

Community Reputation

0 Neutral
  1. No worries will give it a crack in the next week or so thank you.
  2. It starts to open up at 5 psi. I'm assuming that's good. Trying to track down a cheap standard cat but it's ridiculously hard to find. Is it possible to have a blockage or something along them lines in the intercooler
  3. Ahh yeah makes sense. You wouldn't believe how hard it is to find a standard cat to put back on haha I'll try and get the turbo off and go get it flow tested hopefully somehow that flapper is just getting caught or something. There's nothing else electronically it could be or even mechanical
  4. Nah no leaks or anything of the sort, actuator was changed not too long ago. The diaphragm is still good. Maybe take the turbo off and take it to a shop get it flow tested or is that a bit overkill? I have no catalytic converter either it sh*t itself so I punched it out to get me out of trouble, any chance this could be causing me problems?
  5. Hey mate put a hose straight from the turbo to the actuator still seeing at least 15 psi .... No idea what to do now. Still got me wondering what could possibly make the wastegate stay closed and force overboost
  6. Yeah I see what you're saying. It's all complex just a matter of figuring out why the wastegate is staying closed, the boost solenoid has power going to it I checked that today. But I'll do the bypass tomorrow and see what I come up with. If that fails what next? Haha
  7. No worries will give it a try in the morning. None of it makes sense, I changed the actuator awhile ago and it fixed it for a few days then went back to rubbish, I put a second hand boost solenoid in and it worked. Although on reds / accessories it was making a clicking sound constantly I thought it was stuffed too but it actually worked. The original one never made this clicking sound, So I bought a new genuine one put that in and that one also clicked when accessories were on, so I thought it was normal to click. I did some work on the car which it was off road for a few days, punched the br
  8. Cheers mate will give it a go tomorrow, so just run hose straight from the nipple on the turbo to the actuator.? I'd disconnect the wiring harness for the wastegate solenoid yeah? Sorry for so many questions I'm pretty average when it comes to mechanical things
  9. Had the dump pipe off the other night and put a mighty Vac through the wastegate line and at around 5 psi it started to open it, the flapper looked in decent condition. I've tried just about everything now, losing hope for it.
  10. Everything is standard except for the rear muffler delete. I'm not sure the history on the car whether it had other mods before and someone tried to tune it... As is though standard everything. Coming up P1227 closed wastegate failed overpressure
  11. Hi mate yeah I have a boost gauge, it's seen up to 22 psi ? I replaced the actuator, the boost solenoid, map sensor, boost pressure sensor. I'll try and run it straight from the turbo to the actuator, would I leave the electrical side of it still hooked up or bypass it altogether?
  12. Hi there needing some knowledge and advice, I've got a 2003 ford ba xr6 turbo auto. I've owned it for around 2 and a half years now and it's always had problems, biggest one is when you put your foot down and hold boost for more than 3 or for seconds it starts to shudder really bad and go into like a limp or safety mode and wants to conk out, only way to stop it doing it is to feather the accelerator numerous times then goes back to normal. No engine lights come up or anything of that sort. I had the spark plugs and Coils changed when I first got it, changed the wastegate, that fixed it for a
  13. I wouldn't have a clue, guy that sold it to me said he thought the turbo could be stuffed but it works fine no shaft play no damage to the fins either. I'll have to look around for someone in my area who tunes these stock falcon computers
  14. Hi there needing some knowledge and advice, I've got a 2003 ford ba xr6 turbo auto. I've owned it for around 2 and a half years now and it's always had problems, biggest one is when you put your foot down and hold boost for more than 3 or for seconds it starts to shudder really bad and go into like a limp or safety mode and wants to conk out, only way to stop it doing it is to feather the accelerator numerous times then goes back to normal. No engine lights come up or anything of that sort. I had the spark plugs and Coils changed when I first got it, changed the wastegate, that fixed it for a
×
×
  • Create New...