Jump to content


spook

Donating Members
  • Content Count

    157
  • Donations

    $0.00 
  • Joined

  • Last visited

Community Reputation

28 Excellent

About spook

Profile Information

  • Gender
    Male

Recent Profile Visitors

1,850 profile views
  1. Pop bonnet, jump back in drivers seat, fire it up and watch engine Then load up the drive line - any engine movement?
  2. Check drivers side engine mount Mine was stuffed and had the same issue. Replaced then all good
  3. It's times like this that I wish I had a hoist - just love crawling around on cold concrete!
  4. Tight fit but got it in with some mods to the tray
  5. They were expensive mate. Checked one day and noticed they had dropped the price so ordered one - picked up the reverse camera to go with it. Just order one as it's a DYI job It's supplied with good instructions and is all plug n play - very simple
  6. They currently have it for $295 which from memory is what it cost me
  7. Torque Pro, cheap ass bluetooth OBD adapter, cheap ass Samsung P1000 tablet (supports AV out) and ASL video conversion kit Picture not the greatest buts its quite responsive
  8. Interesting. Had noticed the 75% at WOT on my BF and wondered what the heck was going on. All good then
  9. Finally found some wheels I like so I can fit ....
  10. Don't be too concerned with the K's especially as the service history is good as you mentioned. Had my BF initially tuned for at a little over 300 rwkw at about 60,000k's mark. Just had it re tuned at 160,000k's after some additional mods and it's now around 340rwkw. As for the diff bush, I fitted Super Pro comfort (3 bush kit) a few years back. Not too hard a job if your handy on the tools and have a trolley jack.
  11. Scrap that - no go with the manifold gasket Ran fine for couple of days and have the cold start idle issue back - not every cold start though. Replaced throttle body this afternoon - let the car sit for a while. Fired it up - same issue. FARK!!
  12. Changed the inlet manifold gasket last night - fun! Been having issues with cold starts and a P2110 error (throttle actuator control system) On some cold starts it would rev to 2k then drop to 1k and run like a POS. Switch ignition of and on then would be fine for the rest of the day. Other times cold starts would see revs fluctuate between 1k and 2k till warmed up - bit all over the shop. Happy to say after replacement it kicked over first go from a cold start to a nice steady idle. Is now running much smoother than before. Guess the giveaway was when the old gasket fell into 3 pieces when taking out.
  13. Picked them up from Bursons and fitted them myself Did front sway bar mount bushes also


FordXR6Turbo.com Powered by Invision Community

×
×
  • Create New...