Jump to content

Known Issues Fg Xr6T


Recommended Posts

Just called my mechanic, car was in for rough idle/hunting at idle. He said when they put it on their scan tool there was about 20 codes to do with throttle body, cam timing and MAP/boost sensor issues, He also said there is a sensor or group of sensors that has like coolant temp, MAP and boost sensing all in the one sensor. Any of the guys with good knowledge of the FG xr6t able to shed any light on this and if anyone else has had similar problems..?

Link to post
Share on other sites
  • Replies 350
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

Sedan rear diff bushes.

lack of traction, too quick to come on boost and jealous ba owners are the only issues ive had.

I have 3 things to complain about. Diff Bushes needed replacing early. First mod done to the the car with nolothane goodies. I had the gear knob replaced under warranty at 2 years of age. The gear kno

Posted Images

Have noticed lately that when I take off from lights etc I hear a short water rush sound coming from under the glove box area. It sounds like something is emptying from the air con. Have checked the overflow to make sute it's clear and that seems ok. No water is entering the car or anything. Any ideas?

Link to post
Share on other sites

Air in your heater lines than run behind your glove box for the cabin heater, garuntee if you take it to ford they will tell you there is nothing they can do, which is pretty much right. Put a/c to heat and drive round for a bit, then park it till the engine cools, check coolant level is correct, that's about all you can do

Link to post
Share on other sites

On a different note, got my xr6t ute back from the shop today, seems like one or both of my cam sensors have bit the dust, "over-retarding" on bank 1 and bank 2, seems like im up for 2 new sensors, not sure of the price of these but easy to change out myself, then need to relearn cam position and delete codes n she should be sweet :D

Link to post
Share on other sites

I've got some issues with my manual FG mk11 turbo only done ~9,200k and its embarrassing mentioning it around friends!

1. front passenger door trim keeps unclipping (maybe when they did the tinted windows for me?)

2. gear shifter rattles at high rpm!!! (most annoying!)

3. I found tiny oil leaking from around the harmonic balancer on the sump!! (most angry about!)

4. under heavy breaking (not necessary I know) there is now creaking coming from the front end! (it never did it when I first tested the brakes when I bought it but now it does? also I am NOT a heavy breaker at all)

5. the silver/chrome XR badge on the back has a bubble in it!!!!

6. drivers door when winding the window up squeaks/clicks! can hear something moving around when windows up.

Just typing this has actually revved me up a tad. what do I do? go in now? can you just show up and they will look at it? or wait for my 15,000 km service and say what's up?

I also experience with TC off, a TON of axel tramp as soon as there is any form of wheel spin (the first time I spun the wheels was a light test at around 2000 km and it was wet...and it was after the motor was "ran in"

Guys any advice?

Link to post
Share on other sites

^^^^Your oil leak near the harmonic balancer is probably the timing cover leaking.

It is a known issue Fraud fixes under warranty.

Edited by GeGe6
Link to post
Share on other sites

I have a 2010 auto fg turbo and sometimes when braking I hear and feel a clunky/ rusty feel at the rear, its mostly when im not driving fast like when im gonna park or slowing down for speed pumps, but it doesnt always happen, my mates old man recons it could be traction control doing it but im not sure what it is

Link to post
Share on other sites

whats with the (presumably) air-con leaking on my feet though?

haven't heard of that one before...

or the coolant for that matter (it was after a cool, night time drive down the freeway too, so no stress on the car)

Link to post
Share on other sites

I've got a mk11 fg turbo now with 16,000km. It has a slightly rough idle but only sometimes. Revs don't drop or anything it's just annoying. My front passenger door trim is loose, the same window makes a quite ticking sound when winding down. Other than those things I'm pretty happy with it. My question is though, can you still claim warranty if you don't service the car through ford?

Link to post
Share on other sites

End of the day every manufacturer, and model of car has a particular bug and issue. The fords have their fair share if little annoying things. your nothing to deter you! The turbo is a mighty car and there are more good things than bad. Get one you won't regret it

Link to post
Share on other sites
  • 2 weeks later...

I had the 'water rush' sound coming from the passenger side area when I'd take off from lights etc after iding for a bit. It would then do a big-ish water dump (for air con). Followed the advice on here and turned the heater to max with windows down and drove around for a bit. Air con then back to 22 deg - now fixed :)

Edited by Bomber
Link to post
Share on other sites
  • 2 weeks later...

Have found with fuel gauge if you fill it up after only using a quarter of a tank or less the gauge does nor show full. It will reset itself once the tank is run down though. I only have a N/A XR6 but I'm guessing the Turbos could do it as well?

Link to post
Share on other sites

Sorry to be a pain but can anyone direct me to a thread about the zf 6 speed auto. More specifically what to do to sstrengthen it. I just joined and I cant find anything about it. I have a 09 fg turbo and I want to push for about 375rwkw. Amassing all the required bits, but before I do anything I want to beef up the drive train. Custom tailshaft, diff bushes, trans cooler, high pressure lines and valves an input shaft ans a tune for the box. But dont know sh*t about the zf. People keep telling me that if you try tune them they go to sh*t. Anyhelp is much appreciated!!! Thanks

Link to post
Share on other sites

Fair bit on this on the forum in the driveline area. PLUS - Have a look through the build threads for the 400RWKW and up cars. Some of the members went a long way with these transmissions and a bit of research will help you. I know that monstatorque in wa have worked with the ZF and maybe a phone call there as a start. Naturally, there are other shops to talk with.

However - before you run head on into this perhaps selecting your tuner/workshop is first. They will have preferences and some views on how to best get to 500 HP at the tyres. No matter where you live in the land of OZ, it seems to me we have great choices for workshops ( plus pretenders..... hell, nuthin is perfect). And - this forum has some great build threads to help as well.

Link to post
Share on other sites

Has anyone had a problem with the plastic part attached to the bottom right hand side of the drivers set come loose? This is the plastic piece where the seat adjust knob and the electric seat button is located.

I exited my car and it came loose. Can it be fixed under ford factory warranty??

2011 fg luxry pack

http://s16.postimage.org/5recgwtt1/IMG_1724.jpg

IMG_1724.jpg

Edited by pantha189
Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    No registered users viewing this page.




×
×
  • Create New...