Jump to content


Sign in to follow this  
Azid Rush

Sway Bar Linkage

Recommended Posts

Hey y'all :)

Well I got around to fixing the sway bar linkage that I snapped somehow today and thought I might aswell take some pics and document how I did this quite simple job for those who may not be to technically sound when it comes to this sort of thing. Feel free to make it a sticky, feel free to delete it but its here anyway :)

Heres what mine looked like lol

100_0189.jpg

100_0188.jpg

100_0197.jpg

Firstly: Because the sway bar linkage was snapped on mine, the sway bar was sitting solid right against it so in order to do this job I had to jack the car up by the solid base near the sway bar therefore, lifting the sway bar away from the linkage and into the spot it should sit to join the new linkage up.

100_0190.jpg

Once you have done this, You need to remove the wheel on the side it is so you can get to the top bolt of the linkage.

Then its time to undo the nuts to the linkage you are replacing. The one that I snapped, had size 14 nuts but I guess yours may differ depending on when it was made as the one I bought to replace it has size 17 nuts.

100_0192.jpg

One nut is on the inside of the wheel directly underneath the sway bar while the other nut is located on the back side of the break rotor. Depending on what tools you have, you may need to use an extension on the ratchet to get this bolt undone.

You can see in the pictures above where these bolts are at. Once undone you can remove the linkage.

Get the new sway bar linkage and take the nuts off. You have to move the ball joint at both ends around until they fit through both the holes. Do up both nuts and go back and tighten them right up.

100_0191.jpg

100_0196.jpg

100_0194.jpg

100_0195.jpg

Replace wheel and lower car. Make sure wheel nights are tight and secure.

Bobs your uncle, fannys your aunt and you have just replaced your sway bar linkage!

Share this post


Link to post
Share on other sites

thanks guy, hopefully it helps someone out

etm - when mine broke, I got a real bad knocking sound in front end, is that what urs is? what sorta creaking sound? high pitched?

felix - not sure how I snapped it ay :S It started making the sound when I was down in canberra on a weekend trip, but the week b4 I started bottoming out in places I never usually would (stock ride height).

So im thinking that I must have hit a driveway bit too hard or just wear and tear cracked it, then the long trip down to canberra just finished it off

Share this post


Link to post
Share on other sites

etm mine makes the same noise, at slow speeds tuning left to right, driving up curbs/driveways ect. ford think its my sway bar making it and are certain its not the steering (I've already had that done) I'll let you know

Share this post


Link to post
Share on other sites

bloody fraud

guess Ill tell the stort of the sway bar linkage at ford spares too lol

I go into ford spares and ask for a price for the sway bar linkage. Old mate tells me it is $52 but will have to go into town to pick it up at the spares shop there. I go in there, they tried many times to tell me that it was the right part they were giving me, and it WASNT lol After a while when they couldnt find any other parts they said try it, if it doesnt match one on car, bring it back. So I said fine, then they tried hitting me $96 for it. I said to them that they can stick it lol and I went to pedders and got the part for $50

so to add to the sticky

Part: from FORD: $96

PEDDERS: $50

Share this post


Link to post
Share on other sites
good write up dude.

my ute has a funny creaking sound coming from the front end,I bet its my swaybar bushes or something

Ive had heavy creaking from my front end for over 12 months now which ford cat fix. I think it might be the swaybars but it only EVER does it in the wet, never the dry. every bump, speed hump and driveway creaks to sh!t each time its wet.

Share this post


Link to post
Share on other sites
etm mine makes the same noise, at slow speeds tuning left to right, driving up curbs/driveways ect. ford think its my sway bar making it and are certain its not the steering (I've already had that done) I'll let you know

well I just fixed mine,it was the actual steering rack,I backed the bolts off and then did them up real tight and now the creaking is gone

post-11256-1201121841_thumb.jpg

Share this post


Link to post
Share on other sites

Ive had heavy creaking from my front end for over 12 months now which ford cat fix. I think it might be the swaybars but it only EVER does it in the wet, never the dry. every bump, speed hump and driveway creaks to sh!t each time its wet.

I had the same thing, I took the sway bar bushes off opened them up and greased them put them back on problem solved

Share this post


Link to post
Share on other sites

Ive just taken the bushes off and coated them in grease. I used a castrol, high tempreture and high compression resistent grease. Absolutely caked the stuff on inside and out.

When I took them off, the bolts holding the bracket over the bushes were all fairly loose, thanks to the last time it was at Ford and the bushes themselves were dry as a bone. Now all I have to do is wait for it to rain and go for a spin. Fingers crossed and the 7 times it went into Ford they couldnt do it???????????

Share this post


Link to post
Share on other sites
Hey y'all :)

Well I got around to fixing the sway bar linkage that I snapped somehow today and thought I might aswell take some pics and document how I did this quite simple job for those who may not be to technically sound when it comes to this sort of thing. Feel free to make it a sticky, feel free to delete it but its here anyway :)

Heres what mine looked like lol

100_0189.jpg

100_0188.jpg

100_0197.jpg

Firstly: Because the sway bar linkage was snapped on mine, the sway bar was sitting solid right against it so in order to do this job I had to jack the car up by the solid base near the sway bar therefore, lifting the sway bar away from the linkage and into the spot it should sit to join the new linkage up.

100_0190.jpg

Once you have done this, You need to remove the wheel on the side it is so you can get to the top bolt of the linkage.

Then its time to undo the nuts to the linkage you are replacing. The one that I snapped, had size 14 nuts but I guess yours may differ depending on when it was made as the one I bought to replace it has size 17 nuts.

100_0192.jpg

One nut is on the inside of the wheel directly underneath the sway bar while the other nut is located on the back side of the break rotor. Depending on what tools you have, you may need to use an extension on the ratchet to get this bolt undone.

You can see in the pictures above where these bolts are at. Once undone you can remove the linkage.

Get the new sway bar linkage and take the nuts off. You have to move the ball joint at both ends around until they fit through both the holes. Do up both nuts and go back and tighten them right up.

100_0191.jpg

100_0196.jpg

100_0194.jpg

100_0195.jpg

Replace wheel and lower car. Make sure wheel nights are tight and secure.

Bobs your uncle, fannys your aunt and you have just replaced your sway bar linkage!

Looking at it , its bent, I think you hit something. But if you want to send it to me,I will tell you why it failed as Iam a metallurgist. Pm me if you like.

Share this post


Link to post
Share on other sites

I had the drivers side linkage snap on my car (BF), my brother had both his snap on his (BA) not at the same time, had my cousins drivers side snap on his (BA). seems common, any stronger aftermarket replacement parts?

Share this post


Link to post
Share on other sites

My swaybar itself snapped in two the other night, at the bend as I went into a driveway. An afterarket Whiteline one that I cant blame Ford for.

Pics to come.

I.B.

Share this post


Link to post
Share on other sites
Ive had heavy creaking from my front end for over 12 months now which ford cat fix. I think it might be the swaybars but it only EVER does it in the wet, never the dry. every bump, speed hump and driveway creaks to sh!t each time its wet.

Since the swaybar snapped in two pieces ive answered my own question from 18 months ago.

I.B.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Donation Box

    Please donate to support the community.
    We appreciate all donations!


FordXR6Turbo.com Powered by Invision Community

×
×
  • Create New...