Jump to content

Gh0stk1ll3r

Member
  • Content Count

    25
  • Joined

  • Last visited

Community Reputation

4 Neutral

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

  1. Hi everyone. I've recently developed a problem with my BA XR6 Turbo that's got me bested. When its cold, I cant throttle without the car leaning out and nearly conking out / poping in the intake. Being persitant with the throttle makes the problem pass and goes on to disappear completely when the engine warms up over a quarter gauge. What I've replaced: Brand new Genuine Bosch O2 sensor. Brand new Genuine Bosch Fuel Pressure Reg. Cleaned Factory Injectors. Brand new Ryco Fuel Filter. Brand new Walbro 255LPH Pump. These were done prior to issue arrising and car was driven faultlessly for about 1500Kms. Since developing the issue I've done: Brand new Genuine Spark Plugs. I've scanned the car, it's not throwing any codes. My current fix has just been idling the car till warm and then going on with my travel. Cheers in advance.
  2. I'm using the GFB Gforce 3 for a reason, I've got an N/A loom so no factory boost control. Anyway all that aside I fixed it this weekend. I found my fuel system wasn't going into Closed Loop as it should and my O2 sensor voltage was static. New O2 sensor and I was getting into Closed Loop but it'd still jump back into Open Loop Fault and run obscenely rich. Pulled my reg and found the filter destroyed threw in a new one and now I'm good as gold.
  3. Hi mate, thanks for the reply. Just had the PCM retuned, still having the issue but I'm throwing a different code now. P1131 I have an idea, I was checking my PCV valve vacuum line routing today and noticed my line doesn't have a Check Valve in it. Could this be the source of my issue? Boost pressure in the rocker cover? Thanks
  4. Hi everyone. I'm one more ETC light and throttle cutting limp mode away from burning my car to the ground. A year-ish ago some of you may remember me searching for help to get my BA XR6T engine running in my blown up BF XR6 on its NA PCM. Fast forward to today and I'm loving the car, except for when I try to overtake or have a little fun. In any gear (Auto) you can not rev past 50% throttle travel. In Park it revs to the floor no issues. It was suggested that my ABS sensors may be dirty, they were indeed dirty, but weren't the problem. I've since tried a different TPS, different Throttle Body and checked the entirety of the engine for vacuum leaks or the such, no dice. I'm throwing one code P0420, which stumps me because as far as I know that's a BF code, and I've got a BA tune. Has anyone else had this issue? I've found similar ones but none trigger like mine do. Could no boost refernce in the PCM cause this? My tuner left the factory boost control in the tune, and due to the problem im having I've not yet been able to road tune my GFB Boost Contoller. My boost gauge has never read higher than 4.5 PSI and cuts at any boost level. I did notice my AFR gauge reads around 10.00 before it cuts. Rich? I appologise for the barrage of questions. Thanks legends.
  5. I've got this system behind an X-Force Dump and Cat on my Turbo sedan. They sent me the wrong system by freight, took over a week to arrive and then I had to wait just as long to get the right one. Not as loud as I'd like, alignment was very very bad, I had to moddify the flange on the cat side of the Y pipe and clearence my floor, a lot. It crackles and pops on deceleration but that's not enough to salvage the brand from the horrible install. Wouldn't buy again. 4/10
  6. Hello everyone. Trying to troubleshoot a problem with my Turbo that about has me ready to burn the thing. Any application of throttle more than a half pedal and I loose all power and the ETC light comes on. If I slow to a stop the car idles surging with no throttle. Key off and on and you're good to go. I've replaced the throttle body to no avail, should I replace the pedal? Cheers.
  7. Cheers for the info, so for those select few XRs that were optioned with LSDs. Would they be the same as Turbo LSDs? Cheers
  8. Hi everyone. Just trying to find out the difference between the BF ZF diffs? Is the turbo LSD the same as the N/A LSD? Cradles the same? Tailshafts? Cheers everyone.
  9. Build update. Car is running and driving. All the gear from the Turbo has been installed save for the NA ZF 6Speed, PCM and engine loom. Boost is controlled by a GFB GForce 3. 3.46 LSD at the back. Tuning is just around the corner. Pics to come.
  10. @k31th Should have the project ready to turn key by this weekend. I have hopefully one last question. I have to incorporate boost control into my N/A loom. Would I be best to splice the boost control wiring from the BA XR6T into the BF N/A loom, pull the loom out and replace with BF XR6T loom or run an aftermarket Boost Control. Thanks for all your help, it's very much appreciated.
  11. Hi everyone, project is going well, getting close to firing it up. Just checking what I need to do to safeguard my gear pre tune? Like run the NA MAF, injectors and bypass the turbo? All this is very new to me, I'm clueless when it comes to turbos. My tuner is an hours drive away, and im hoping I can drive it there, but I'll trailer it if I have to.
×
×
  • Create New...