Jump to content

my 03 ba xr6t wont go past 4k revs


Seth
 Share

Recommended Posts

  • Member
  • Member For: 6m 8d

Hello I just replaced the stock turbo as my other one was on its way out and and now I have a problem where if the car is in neutral I can rev it past 4k revs but when I'  in drive and driving I go to step on it and when it gets to about 4k revs and has a misfit and its like its cutting boost or something but every time it doesn't go past 4k revs it haves like a little pop to it like a pipe blow off but then ill check all my pipes and they are sill all on so I have no clue what I have done wrong if anyone knows plz help me out I'm getting sick of having to fix the I <3 Bananasen thing. 

and it has been sitting for about 2 months with the same fuel of 98 that wouldn't make the car do that would it?

Link to comment
Share on other sites

  • Replies 35
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Posted Images

  • Member
  • Member For: 6m 8d

Only things I have done to it while I have owned the car is replace STOCK TURBO which means it’s stock so it’s almost like it wouldn’t need one if it’s the STOCK one yeah? And a bigger intercooler and that is it it has a fuel pump and stuff from the previous owner everything was perfectly fine until I replace the STOCK turbo.

Link to comment
Share on other sites

  • Member
  • Member For: 6m 8d

I emailed the Company asking if this is a factory stock replacement with the same size actuator as the stock actuator they replied back and also said it is a stock factory replacement turbo. 

Link to comment
Share on other sites

  • less WHY; more WOT
  • Site Developer
  • Member For: 14y 1m 8d
  • Gender: Male
  • Location: Melbourne

Then it's not the same. Plus, you said the company you bought it off said it's the same as an OEM one... but are you 100% sure the one you took off was an OEM one?

Link to comment
Share on other sites

  • Member
  • Member For: 6m 8d

I have a video here it only lets me show 5 secs of it cos the file is to big or something but I thought the brand of turbo didn’t matter so long as it is same specs? Or am I wrong? I’m sill learning sh*t everyday ahah and the one I took off is a gt3582 I’m pretty sure it looks like one and that one was a Garret

Link to comment
Share on other sites

  • less WHY; more WOT
  • Site Developer
  • Member For: 14y 1m 8d
  • Gender: Male
  • Location: Melbourne

this site isn't for hosting video :)  use youtube or similar and then post the link in here if you need to post a better video.

 

27 minutes ago, Seth said:

the one I took off is a gt3582 I’m pretty sure it looks like one and that one was a Garret

just because you took one off that looks like a GT3582, doesn't mean it actually is. It's entirely possible it was a FG turbo or similar or even a modified variant etc, both of which scenario could cause your current circumstances.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.



×
  • Create New...