Jump to content

Lean/popping at low rpm


Recommended Posts

Hey legends. Got an issue I can't seem to work out.

 

Ba turbo. Has Bosch 440 injectors, Walbro 342 pump, valve springs and flapper mod. 

 

I have an intermittent fault where under light throttle it will lean out (on the afr guage ) and will pop from front (sound alike airbox area) and not accelerate. It happens at low revs. For example cruising along at 60 and road goes uphill so you increase the throttle slightly it will lean out/pop or on freeway at 110 if you give it a little bit (before it kicks down) it'll do the same. 

 

The fault is intermittent as some days it runs faultlessly.  

If you put your boot in and it kicks down and hits boost its fine. No issue. 

 

 

 

Things I've done.

- replace fuel pressure reg 

- replace O2 sensor 

- replace plugs 

- check for vac leaks (car pulls very good vacuum according to the guage) 

 

I did pull the fuel pump and the wiring from the Walbro pump up to the top of the cradle was melted.  I have replaced the cable with no luck.  

 

 

I'm just wondering if anyone else has experienced the same issue and could guide me on what to test next as I've run out of ideas and I'm pulling my hair out. 

 

Cheers legends

Link to post
Share on other sites

What codes are present?

 

Sort that wiring out with a relay mod first and see if it still acts up. It could be something else but no point guessing at this stage.

Link to post
Share on other sites

Hey mate, 

 

It has a venom cat. 

Tune was done by JD tuning (I believe he is on here) 

 

I bought the car about 2 years ago as it is.  It's been fine up untill a few months ago and it progressively getting worse.

 

Funnily enough if I disconnect the battery over night it tends to run really good for a few days before it goes back to how it is. 

 

It's quite odd that it's only on light throttle/low rpm.   Once it hits boost its fine. 

Its an odd one

Link to post
Share on other sites

Hi OP

 

I’m JD TUNING ADELAIDE, is this a Phantom purple or a toxic Green BA turbo ? 
 

Feel free to send me a P.M and I might be able to fill you in on the history of where either of these cars went after I worked on them and I’ll be happy to help you get her right again :) 

Link to post
Share on other sites

Hey mate

 

worked out what vehicle this is, reason I didn’t click straight away was because I didn’t actually do anything too it except re tune it back to a safer point as the previous owner didn’t want to spend the money fixing it correctly unfortunately… 

 

have a look on page 199 ( here ) then page 200 for how I rectified the tune only on it :) 

Link to post
Share on other sites

Well same deal applies, I’m happy to have you in and get it to a point where it’s modified to a better standard as it definitely had some questionable items on board despite whats being seen on the fuel pump picture. 
 

The old girl has potential and it would be great to see her with some good parts and hopefully get into the 300rwkw club :) 

 

Anyways if you want me to look and deal with what’s currently wrong with it feel free to P.M me and I can sort her out / fault find and diagnose a rectification path. 

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...