Jump to content
Danny_

Ecu issues

Recommended Posts

Hi guys,

just having recently fixed my issue of the car having issues to idling I now am having issues wuth the second issue. 

 

Car is a 6cyl ba Fairmont ghia with a 4 speed auto. 

 

Ever so often it would go into limp mode and the gearbox would throw codes, 

Changed oil and filter and that did. It resolve the issues.

A search online shows it could be the ecu and I replaced that and this is where more issues start. 

I went from a 32AE to a 32AD ecu and had it programmed. 

Took the car for a drive and the second it changes gear throws it into limp mode (speedo doesn't work either) 

He tried to reprogram it and tried again, same code p0500. 

Could I have been sold an ecu for a Ute and not a sedan?  

It keeps looking for a speed sensor that the Ute's have and sedans don't have, 

The guy that programmed it wasn't sure if Ute ecus will work in sedans. 

Thanks. 

Daniel. 

Share this post


Link to post
Share on other sites

well, you definitely need to either get somebody who knows how to re-program the strategy on the PCM (it's Ford's name for the ECU) to suit a Sedan versus a Ute variant, but if you're sticking with the same guy, then get the same model variant of the PCM (it should be fairly cheap considering you're after an N/A one instead of a turbo one) at a wreckers and get that coded for your car.

Share this post


Link to post
Share on other sites

Sorry for all the spelling mistakes and the poor formatting. It wouldn't let me edit it and I was taking the train to work 😕

The guy that programmed it came recommended by the person I bought the ecu off (Ford pro wreckers) and the programming set me back $200

I am not sure if many people can program the ecus. 

 

I am used to driving 40+ years old cars with no bloody ecus. 

Share this post


Link to post
Share on other sites

your spelling was fine :idunno:

 

well, go back to the same guy with a correct PCM and get it re-done correctly by him, under "warranty for work" or whatever you might be able to get through him, as he clearly didn't get it working to a satisfactory level.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Donation Box

    Please donate to support the community.
    We appreciate all donations!
×
×
  • Create New...