Jump to content


Recommended Posts

Hi everyone, 

 

I currently own a G6eTurbo 2010 model with approximately 100,000 kms. I have done nothing to the car besides a rear muffler delete, besides this it is stock as a rock. 

The other week I was driving on an expressway travelling at about 100 kmh and then accelerated, not an overly hard acceleration but was overtaking someone so a reasonable push.

As I put the power in the car lost power and flashed “Transmission fault” on the display. It put me into limp mode (3rd gear). I pulled over turned the car off and turned it back on and it appeared fine let me drive normally.

I took the car into a mechanic and explained my problem but they said they couldn’t find any codes and they test drove the car which appeared fine to them.

Since this I have tested the issue myself and found once the car hits operating temperature if I apply any hard acceleration after about 100 kmh the car immediately faults, limp mode, turn it off back on and it runs fine. I borrowed a reader and found the following code myself:

 

DTC - P0735 - Transmission gear #5 incorrect ratio. DTC status: Continuous memory DTC.

 

Has anyone had this issue or know what is going on with my car! I don’t want to keep mechanic shopping and being charged silly amounts to be told its fine. Any help is greatly appreciated.

Share this post


Link to post
Share on other sites

have your ignition coils been changed before?

 

Caused some weird ass transmission sh1t for me, but not that specific fault code.

 

it's at the kms where you want to service your box as keith said above. when servicing it should become clear if the box is torched.

Share this post


Link to post
Share on other sites
2 hours ago, G6eTurboDaily said:

I’ll look into a trans service anyone know the rough cost

There's a few good write up's on the site about it if you're inclined to do it yourself.   If you take it to the pro's you probably looking at anything beyond $1,000   from memory its ~300 for the kit plus 70ish per liter for genuine ZF fluid of which you need about 14 liters for a full fill and labour on that.  If you use dextron6 ZF compatible fluid you'll save a fair bit on the oil.  

 

The reason I ask about the wheels, there was something I remember with the Simmons I was going to get.  Guy at the shop had said it could trigger ABS faults for some cars based on a different rolling diameter because of the sidewall ratio.  I'm not saying that's the cause here, but maybe a bit of slippage in the box plus the wheels could be doing it? 

Share this post


Link to post
Share on other sites
On 19/04/2019 at 11:25 AM, G6eTurboDaily said:

I see. Ignition coils haven’t been changed at all. I’ll look into a trans service anyone know the rough cost I’d be expecting and if the gearbox is “sealed”?

Gearbox is not actually fully sealed they just do not have a level indicator for general users to check, they do have fill points on the side of the gearbox that are technically used to check the oil level.

 

I recently serviced my ZF, 

 

Metal replacement pan and filter, from eBay $185.

20l of gulf western oil, was about $200...

you can order it online from SCA but im in WA and they could not guarantee a reasonable shipping time (shipping was from over east, via road). I ended up going to repco and getting it same price same day.

I also bought a transmission cooler to replace the factor w/o cooler, that was $310

 

service is made easier if you have the OBD2 adapter and can load up the transmission temp, as you need to fill it twice (once cold and once when it between 40-60deg-from memory)

 

I think I ended up using about 18l of oil as I drained oil, added oil and drained oil a couple of times to try and clean out all the old oil. I believe the full dry refill is about 10l and part refil is about 4/5l (aka just sump)

 

there is a thread on here somewhere with the ZF service guide, if you going to diy read it twice before starting, make sure you know what your up against.

 

I cant tell you how much a mechanic would-charge to do the above.

another point of mention here is that I bought the cheapest oil I could find with a ZF raiting, certain places may like to use the genuine stuff that is about $50 per L.

Share this post


Link to post
Share on other sites

If you ring Gulf Western direct, they will supply 20L delivered to your door for about $150. Bargain!

After doing that for the trans oil, I get all my oil direct from them now.

Share this post


Link to post
Share on other sites

G'day G6eTurboDaily,

 

Have seen something similar on my mates F6, his dashboard would light up as well when under load and changing gears, the gearbox was saying something like 'over maximum torque limits'.

From memory it was all to do with the time between clutches letting go and grabbing while changing gears. He did however managed to get his gearbox re-programmed locally (here in Adelaide) for faster shift times between gears, it seemed to solve the issue.

 

Dunno if this helps but its just my 2 cents... maybe try the service first...

Edited by DrG6E

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

  • Donation Box

    Please donate to support the community.
    We appreciate all donations!


FordXR6Turbo.com Powered by Invision Community

×
×
  • Create New...