Jump to content


Rab

FG MK 1, 2, FGX, BA/BF and Territory replacement ICC

Recommended Posts

https://mega.nz/#F!pUFh3aRS!RoM0sdzTe7AU3HNeNvZCUQ

Download that as a zip to your PC. Unzip it and copy the contents to a USB.

Plug the USB into the unit, go to settings, car settings then hit update MCU.
It automatically starts from the goods on the USB, there's also a canbus update which you can install after the update. To do that navigate to the USB through the file explorer app and boom your updated.


I'd run your car whilst updating it as any power cut could brick it cos android.

Share this post


Link to post
Share on other sites

Just bug fixes as far as I know, pissweak I found it via aff not from the Kayhan site.
They have a video but it doesn't really show how to do it.

From what I noticed, dual zone now works properly and outdoor temp seems faster/more accurate.

Only used it for 5 min so can't say that's it for sure.

Share this post


Link to post
Share on other sites

Cheers.

 

Was halfway through taking pics of mine on how to set the dual zone when you posted that you'd updated and fixed it.

Share this post


Link to post
Share on other sites

I ain't that thick lol. I used the settings app, never bloody worked.


Needed more testing on their part but seems to be a good thing now they've ironed out the bugs.

Share this post


Link to post
Share on other sites

So now I'm not getting sound from Spotify, acts like it's working but no sound.

Radio and YouTube still work so it's not completely broke.
Plenty of teething problems.

Share this post


Link to post
Share on other sites

Yeah that was my photo he'd posted reusing the pins from one of the aux inputs.

I've still not used it in the end as there was too much feedback using the mic 5v power wire. I'll have to find another way.

Strangely, apparently you "must" use the external mic with the MK2 version, which I find strange - even when putting it into a MK1 like mine which has the mic built into the front ICC cover. I've tried calls and there's a one way voice issue, which changes when you use the on screen speaker button (goes from hearing the caller and no mic to them hearing you but not being able to hear them). Either way it seems like they should be able to fix this of a MK1 facia is used.

Overall I'm still happy, it's miles better than the original MK1 unit. And I was lucky enough to get the newer fast boot model

Share this post


Link to post
Share on other sites
So now I'm not getting sound from Spotify, acts like it's working but no sound.

Radio and YouTube still work so it's not completely broke.
Plenty of teething problems.
Left the battery off overnight, seems to have fixed it.

Share this post


Link to post
Share on other sites

Pro tip.
When knobs play loud doof music at the lights turn up the volume and play prons cos the Kayhan has interwebs. The looks are priceless

Cheers.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Donation Box

    Please donate to support the community.
    We appreciate all donations!


FordXR6Turbo.com Powered by Invision Community

×