Jump to content

BA Fairlane Turbo!


skotty
 Share

Recommended Posts

  • Member
  • Member For: 8y 5m 19d

Had to make a new account, I'm not sure what went on there.. I think I had logged in via facebook some how last time and can't anymore? 

 

Anyways... This poor car is starting to look pretty sad and sorry for itself.. Bought a new car last year (don't shoot me! 2014 VF Calais V V8 sportswagon) and the fairlane and put in the shed and forgotten about.. Did take it roll racing in october last year at the bend, that was a cracker night, but car was slow and was only on 98... While it spend 7 months parked up it devolved a starting issue where it was a real *beep* to start like a 1974 victa 2 stroke mower with a fouled spark plug! Would take 5 attemps at cranking it to get it to get and it would eventually fire.. Bypassed the surge tank and it seems to be back to normal now.. Has anyone here had a issue with the peirburgh fuel pumps on the plazmaman sure tanks? It's only 12,000kms old but has sat around quite a bit.. I want to get back into this car and enjoy it, as nice as the 6ltr VF is, and personally I do like it more as a "road/drive car" the lane is the pride of the fleet. 

 

it's starting to resemble a barn find these days! 

155512883-1089821094762819-8324194838586

And looking all nice and stock like on the way to roll racing! 

120853732-989459358132327-73243470493651

120804566-987390891727950-58526161906668

Edited by skotty
Link to comment
Share on other sites

  • ...JD TUNING ADELAIDE...
  • Gold Donating Members
  • Member For: 14y 1m 2d
  • Gender: Male
  • Location: Adelaide

Solid build mate ! 
 

Pierbergs on the Plazmaman UCST are usually set and forget with not one issue yet around all my customers so maybe a first or something else going on ? 

  • Like 1
Link to comment
Share on other sites

  • Member
  • Member For: 8y 5m 19d

yeh unsure mate, I was talking to my tuner and it had me stuffed, they haven't seen one fail either.. I figured I'd by-pass the surge as 1 last attempt to to fault find before the 3000km headache of getting it into the shop.. If I let it sit overnight with the connected the next day it was a total dog to try and start - even sitting for a few hours it would be a pain.. I went back to stock tune, stock injectors and it was the same.. I left it for 5 days without touching it on just the in tank pump and it was like a normal car to do a cold start on again.. Tuner said it did sound like maybe the pump was lazy when cold AFR's according to the gauge were fine though..

 

Unless it is a issue with the harness I use for the surge..

Link to comment
Share on other sites

  • Member
  • Member For: 8y 5m 19d

having a dig around today at my surge wiring and a discovered that the wiring from the fuse holder is melted which isn't exactly ideal. Seems when my loom was made (back in the day it had a single 044 not the peirburgh) it had some thinner wire coming from the fuse holder, then went to some thicker gauge stuff.. I'm not too sure if this would be enough to of upset the apple cart and made the car be a complete pain in the arse to start.. I've also had my tuner and another shop tell me to have the power for the surge from the fuse box.. Currently it comes off the back of the starter, which works but I've been told isn't 100% ideal so I'll have to replace part of the loom so I'll re-route that at the same time. 

 

I just wanna get the car upto spec now some issues are sorted - and see if it can make the power on e85 that it was spouse to make, and go PCMTEC flex tune. 

 

And now there is E85 on pump in Mount Gambier I am more motivated to get it sorted out! it had issues leaning out on e85 when it was being tuned, which I think I have since sorted out which ironically enough so did my old car this was re-shelled from but that had a different pump setup.. 

Link to comment
Share on other sites

  • less WHY; more WOT
  • Site Developer
  • Member For: 14y 2m 23d
  • Gender: Male
  • Location: Melbourne

if you've still got access to those pictures you posted in the OP, I can fix those for you, if you'd like.

  • Like 1
Link to comment
Share on other sites

  • 2 weeks later...
  • Member
  • Member For: 8y 5m 19d

Pulled my surge loom out, and well not too sure what was the go there but it was rooted to say a understatement. Melted in 3 spots, some male/female joiners in it and the insulation on them was melted.. all up the sh*t so making a fresh loom from scratch. Actually wondering if my pump was trash or the wiring was trash and took the pump put or maybe vice versa, but with the surge bypassed for now it stars like a normal car still. 

 

Also impulsive bought new wheels for the fairlane too during the week. 50th anniversary g6e 19s, so it should look good, just gotta pick them up. Cars been off the road for almost 7 months the so getting keen to get it back on the road and hopefully all the niggly issues sorted. 

received_506716807126496.jpeg

Edited by skotty
  • Like 1
Link to comment
Share on other sites

  • 2 weeks later...
  • Member
  • Member For: 8y 5m 19d
On 02/05/2021 at 5:51 PM, k31th said:

if you've still got access to those pictures you posted in the OP, I can fix those for you, if you'd like.

I have the pics but unsure which ones were used. 

 

Anyways, g6e 19s are on and instantly happy again with with car works on them.. the anniversary 19s, silhouette paint, china beige interior, sunroof all pull together to make a sweet package.  Then add in some boost! 

 

Anyway I need to pull my figure out I've got 3 weeks off work coming up and got a planned 3000km roadtrip I wanna do, and I'd rather take take fairlane over the VF Calais to be honest. Plus this car was built to be enjoyed.

20210516_111751.jpg

 

185388511-218688369748563-74885403779279

 

Just need to find some decent lock nuts, and the correct centrecaps. Oh and wash the damn thing.

 

Are there many blokes on here from SA go roll racing?

Edited by skotty
Link to comment
Share on other sites

  • 2 weeks later...
  • flame magnet
  • Gold Donating Members
  • Member For: 14y 1m 16d
  • Gender: Male
  • Location: adelaide hills- 'race air' central
On 26/05/2021 at 6:05 PM, skotty said:

I have the pics but unsure which ones were used. 

 

Anyways, g6e 19s are on and instantly happy again with with car works on them.. the anniversary 19s, silhouette paint, china beige interior, sunroof all pull together to make a sweet package.  Then add in some boost! 

 

Anyway I need to pull my figure out I've got 3 weeks off work coming up and got a planned 3000km roadtrip I wanna do, and I'd rather take take fairlane over the VF Calais to be honest. Plus this car was built to be enjoyed.

20210516_111751.jpg

 

185388511-218688369748563-74885403779279

 

Just need to find some decent lock nuts, and the correct centrecaps. Oh and wash the damn thing.

 

Are there many blokes on here from SA go roll racing?

Hey mate, nice write up and build.

My car is having a few improvements made as we speak after sitting pretty unloved or driven for a few years. After my lad took his newly modded fg to the bend a few weeks ago and showed me the vids I'm keen as a bean to give roll racing a go. 

 

Happy to meet up for a cruise too if you're interested- I live up in the hills, so plenty nice roads to explore.

  • Like 1
Link to comment
Share on other sites

  • Member
  • Member For: 8y 5m 19d

Unfortunately I live in little old Mount Gambier and don't get upto Adelaide much.

 

Had a oh sh*t moment today, putting the rocker cover back in, snapped a bolt for it in a cam cover. Not too sure if I will get a ezy out and try to tackle it myself or send it into a shop to be sorted out.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
  • Create New...