Jump to content


jiri styles

FG XR6 turbo sounds like a cop siren

Recommended Posts

hey guys, just recently got a fg xr6 turbo, and it is making the funniest noise on acceleration, soon as you start to accelerate the cop siren noise starts and stops as soon as you let off the throttle, and itgets really loud, it also does on when free reving in neutral but not loud, there is NO performance issues at all it drives great so far, boost is fine and everything, just the loud cop siren noise through the whole rev range is there and I have searched everywhere for answers and I cant even figure it out, im thinking mabey the alternator or a pulley or 2..

Share this post


Link to post
Share on other sites

Nice revival - 5 years since your last post ...

 

@k31th could be banshee exhaust ? :wwww:  Farrk luv that banshee exhaust - made my eyes water every time I heard it on that Snowy's cruise so many years ago ...

Share this post


Link to post
Share on other sites

5 years since signing up... this was his first post :P we have a lot more lurkers than posters.

 

that exhaust didn't sound anything like a cop siren, though... this description is... just not adequate to diagnose anything.

Share this post


Link to post
Share on other sites

sounds like alternator whine... e.g. bad earth interference. Usually happens on a falcon when you put in an aftermarket sound system and use the factory audio signal (not a head-unit) and boost it up with an amplifier... the factory earth system just isn't well designed for the higher current draw of an aftermarket sound system...

 

take it to an auto-elec and get them to diagnose the bad earth source, if you don't know how to do it yourself :)

Share this post


Link to post
Share on other sites

yea man , first thing I did, I will take the serpentine belt off tomorrow and let it idle and see if the noise is still there

 

1 hour ago, k31th said:

sounds like alternator whine... e.g. bad earth interference. Usually happens on a falcon when you put in an aftermarket sound system and use the factory audio signal (not a head-unit) and boost it up with an amplifier... the factory earth system just isn't well designed for the higher current draw of an aftermarket sound system...

 

take it to an auto-elec and get them to diagnose the bad earth source, if you don't know how to do it yourself :)

 this does make alot of sense I do think it is alternator also..

Share this post


Link to post
Share on other sites

Sounds like electrical interference to audio system to me as well.  Nice vids by the way :thumbsup:

 

I used to get a similar whining sound on my previous BA when I connected car cig lighter to my phone to charge it at same time as using a FM transmitter into car audio FM receiver to play mp3's off my phone ...

Share this post


Link to post
Share on other sites

I have a NA xr6 sedan also and I get no whine from the engine bay at all, just when im listening through the FM transmitter but its not really a issue, but in the  xr6 turbo its loud from the engine bay and in the cab when the FM transmitter is on or off

Edited by jiri styles

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Recently Browsing   0 members

    No registered users viewing this page.

  • Donation Box

    Please donate to support the community.
    We appreciate all donations!


FordXR6Turbo.com Powered by Invision Community

×