Jump to content


masda74

Fg Xr6T Going In For Mods And Tune Soon.

Recommended Posts

Nah mate, has to be a dud relay or something not calling for the comp to run.
Mine has started to do the same thing but it only seems to be after its sat for a week, if it's driven daily it's fine and always works the second time of it doesn't the first.

Share this post


Link to post
Share on other sites

Thanks for the pointer. mine is a daily. gets driver Monday to Friday and sometimes on Saturday/Sunday.

Might have to take it in for a service at 112500 and get Rob to have a look at it then.

If you think it is a relay, then I take it that it would be a relay in the engine bay with the rest of the fuses?

Share this post


Link to post
Share on other sites

Funnily enough, I know of 3 FG's that as the batteries were failing, the AC would stop working. New battery and suddenly perfectly working ac.

Seems system voltage would drop too low on cranking and the computer wouldn't allow the ac to switch on. 

This happened to my ute and two non turbo sedans.

If you daily runs are too short you can run your battery down. Maybe the new unit needs a good charge if it was never fully charged to begin with?

Share this post


Link to post
Share on other sites

I should have replied earlier.
Mine turned to be the ac relay was cooked but it could have been caused by the battery which was in average condition at the time.

Fg's are getting on 10 years now so I guess these kind of issues will start popping up.

Share this post


Link to post
Share on other sites
18 hours ago, Breeny said:

Funnily enough, I know of 3 FG's that as the batteries were failing, the AC would stop working. New battery and suddenly perfectly working ac.

Seems system voltage would drop too low on cranking and the computer wouldn't allow the ac to switch on. 

This happened to my ute and two non turbo sedans.

If you daily runs are too short you can run your battery down. Maybe the new unit needs a good charge if it was never fully charged to begin with?

So I replaced the battery early/mid march. all been working fine since. I thought my trips were to short to work as they are only 20-30 mins depending on traffic.

I even topped up the distilled water and left the car on a trickle charger over the weekend. Monday had no issues starting. Tuesday no issues starting until I went to pickup my kids at school. I was left stranded with the car not wanting to crank over at all.

 

Damn embarrassing especially with a Ford. Had to let the car roll back down the hill backwards and then kick start it in reverse.

Clutch did not like me at all, but she phucken started. I was fuming and Drove off quietly. I was so tempted to do one huge burnout to try and charge it in 30 seconds.

I went and bought a new battery that arvo.

 

No it is not because it is a ford, it is because it is a Century battery. Price for these damn things have gone up over the years. I remember buy the first one at $169 and thought it was a bargain. Now they are at $235 clams.

Share this post


Link to post
Share on other sites
24 minutes ago, masda74 said:

Had to let the car roll back down the hill backwards and then kick start it in reverse.

 

Lol at least a manual is good for something hey?! :stirthepot:

 

#tractorlyf

Share this post


Link to post
Share on other sites

I’ve removed over 30 century battery’s from falcons and cleared faults,DSC issues,A/C issues,idle issues and starting issues 

 

My local Century rep that comes through the spare parts store finally has believed me the falcon doesn’t like his battery’s 

 

I know you'll all be thinking a battery is a battery but century go about their lead plating process differently that other battery companies do and this causes issues on the falcon platform 

 

I’ve had some decent skeptics turn their nose up on this but take my word for it a Supercheap brand battery will out go a Century and have least issues on a falcon specifically ! 

 

I NEVER use a Century battery ever after coming to this conclusion

 

true story is true 

Share this post


Link to post
Share on other sites

I’ll take that lol 😂 

 

its just one of those areas to nail perfection anyway I can but others have worked this out also years and years ago 

Share this post


Link to post
Share on other sites

Probs won't hurt to check your charge rate - load alternator up with lights on high, AC on etc and make sure she holds 13.8+V no higher than 15.

Also doesn't hurt to check for battery drain, FG's do draw a bit of current for a short while after locking, but will settle down. Anything higher than ~100mA after 15 mins needs checking out.

20-30 mins daily should be fine if charge rate and drain are ok.

Share this post


Link to post
Share on other sites
12 minutes ago, JETURBO said:

I’ll take that lol 😂 

 

its just one of those areas to nail perfection anyway I can but others have worked this out also years and years ago 

No doubt....

Most keep their tricks up their sleeves though

Share this post


Link to post
Share on other sites
21 hours ago, Puffwagon said:
@NA_TURBO You've had some of these issues. Check ya battery?!

Yep checked battery, not the cause.

 

On 13/02/2019 at 8:32 PM, masda74 said:
so the car hit 112000km last week. what really got me this week was the battery finally gave up.
Had to go and get another Century 67EFMF from Supercheap.
The last I remember, I got one for $189.  Inflation seems to be rising higher than my pay rise.
New price of battery is $235. like wtf.
 
Car now cranks over first time every time. only issue that I am still facing now is that the aircon doesn't always work.
Every so often I will turn the aircon on and only hot air comes out.
I have to pull over and stop. Turn the car off. wait a bit start car and then I get cold air.
like wtf? does this mean that it needs to be re gassed? also the cold air doesn't come out as cold as it used to.

My BF does this, but I only have to pull over and let it idle to make the AC turn on then it's fine but it never cuts out. Just stalls when slowing down sometimes.

Share this post


Link to post
Share on other sites
On 02/04/2019 at 10:20 AM, JETURBO said:

I’ve had some decent skeptics turn their nose up on this but take my word for it a Supercheap brand battery will out go a Century and have least issues on a falcon specifically ! 

I NEVER use a Century battery ever after coming to this conclusion

true story is true 

Wish I had known this before. I thought they were a good battery cause of the 620CCA and how it turns the falcon over pretty well.

Did try a supercheap battery when first replacing the original battery and had to take it back cause it was 420CCA and would not crank over the next morning for some reason.

I would go the optima, but securing it would be my biggest concern. would I be able to do it????

 

@JETURBO what battery do you recommend to use then?

Share this post


Link to post
Share on other sites

No mate the reference was really for “any other battery” even a “supercheap” brand with appropriate capacity will out do a Century ! 

 

I Get them from Sprint auto parts but I think they’re a SA company only 🤔

its around $170-$200 depending on sales etc etc and never had one fall over ever 

Share this post


Link to post
Share on other sites

Thanks mate. I did check supercheap site and did enter 630CCA batteries and they only show the century stuff.

Staying away from them from now on. Too late to change now.

I checked the Exide site and their store locator is I <3 Bananased. When I clicked on contact us, it showed some addresses.

I will find a store locally. Thanks again for the information.

Share this post


Link to post
Share on other sites

forgetfulness at old age is not cool. only way to get around it. leave post it notes everywhere.

So the car has been in for a service recently at Monsta torque. 112500km service complete.

Notes on invoice. Need new tires..... :( and need new windscreen wipers.

 

I was expecting more, but I am glad that was all. Went for RE003 again and Bridgestone had their special on again.

I got in on the last day. I ordered 4 tires for the price of 3. I just can't go wrong. Thanks to Marcel at Bridgstone in Malaga!!

He is a legend for giving me a good price.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

  • Donation Box

    Please donate to support the community.
    We appreciate all donations!


FordXR6Turbo.com Powered by Invision Community

×
×
  • Create New...