Jump to content


Guest Scott Greco

Why Wont My Ba Start After Dual Zone Upgrade

Recommended Posts

I fitted duel zone to my ba xr6 turbo to day every thing works but secrity error come up on the icc screen I have tryed every thing to to get it to start over when I checked the pcm for codes it comes up with p1260 theft detected engine disable

and I also checked codes for the cluster and it has a b1342 ecu defect what the hell is the go hear I tryed to program my keys but itg still wont start

hear is the list of parts I fitted if it helps

* green BEM

* duel zone icc unit

* hi series cluster fpv if it maters

* LH mirror with air temp sensor

* lhf door harness

* sun load sensor

* HIM programed to duelzone

* auto lights cobination switch

* I did not replace the dash harness because it has the same part number as a ba mk11 with duel zone fitted

can some one plz help me with this

Share this post


Link to post
Share on other sites

it may be the icc unit and the computer/ bem dont match.

if you remove the icc, the car wont start till the big white plug on the back is connected back in.

the icc is actually part of the security. if the car and icc are not compatible security code wise, that's prol the problem.

perhaps the bem/ computer needs to be from the same car the icc came from? someone verify?

Edited by fordriver1

Share this post


Link to post
Share on other sites

:w00t2:

Although someone did mention on here a while back that it could be done...but offered no elaboration. But yeah basically the bem and icc need to learn to like each other otherwise it thinks you're up to no good and won't let you start the car. :spit:

Share this post


Link to post
Share on other sites

try keep car off, get to security code screen on icc (press volume button if u have to) then hold down FM and MENU for 5 seconds.

See if that trick helps you in any way

Share this post


Link to post
Share on other sites

cheers I will try that lucky the car is not on the road at the moment I want to keep if away from a ford work shop if I can it not quite std any more and a bit hard to get it there

Share this post


Link to post
Share on other sites

cheers I will try that lucky the car is not on the road at the moment I want to keep if away from a ford work shop if I can it not quite std any more and a bit hard to get it there

Not quite standard - that turbo could swallow my turbo whole :fishin:

Any luck yet?

Share this post


Link to post
Share on other sites

got the dual zone all working today I used hanatech scan tool I was just doing it in the wrong order have to program the keys first then do the 10min relink

Share this post


Link to post
Share on other sites

got the dual zone all working today I used hanatech scan tool I was just doing it in the wrong order have to program the keys first then do the 10min relink

Only gust found this thread. What cable/program are you using to set up the car and can you still get it? Sound good that you can program new keys to the bem unit.

I though that it was a major to get new keys programed. Could work out cheaper to buy the cable than to go to ford to replace keys.

Share this post


Link to post
Share on other sites

hey sorry I took so long to reply I thing the hanatech is worth a few grand I browed it from a mate who is an auto leckie I all so found out that the snap on scan to can all so program keys

Share this post


Link to post
Share on other sites

Hey I got ford to do one today and they put the original bem from the old on but their scan tool would not register. Everything still worked like air con, lights door locks and the car still started but no radia cause of "code". So I paid the $300 they charged me to replace it nd reprogram a new key. They only way I can get rid of code temporally is by pressing FM and home button together. Any suggestions to get rid of "code" permanently? And yes ive taken the battery out for a while then started back up it tripped my fuel sensor but not my icc. All fuses seem to be fine. Ford suggested checking the wiring in the car but that could be a big job. Any ideas?

Share this post


Link to post
Share on other sites

I run a stand alone Haltech engine management system. As I had no factory EMS, my ICC could not link and thereby displayed the security code. Car ran, Dual zone etc woked.. I sent the ICC to Fadi, at https://www.aslautomedia.com.au/. They removed the security from the ICC and all is well again. Was $120 total...

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Recently Browsing   0 members

    No registered users viewing this page.

  • Donation Box

    Please donate to support the community.
    We appreciate all donations!


FordXR6Turbo.com Powered by Invision Community

×