Jump to content


Sign in to follow this  
Azid Rush

Power, Earth And Accessories

Recommended Posts

hey guys

went to hook up my new head deck today and for some reason doesnt seem to be any power going to the unit. Ive got it tapped into the blue plug behind fuse box like I did for my last stereo install and seems to be no power. Im sure the unit is in working order.

Can someone tell me an alternative place to tap into power, earth and acc please

Share this post


Link to post
Share on other sites

yeh I cant find my test light

what is that plug actually for? It is possible that there isnt power running through it now?

alternatively is there another place to tap into them

Share this post


Link to post
Share on other sites

nobody guys?

I had a blown fuse which I replaced but still no power going to deck. Dont have a volt meter so I cant test wires but the connections are definately good and I had the deck checked out today and it definately working so its in the wiring somewhere.

Can someone recommend a decent place to tap into 12v, acc and earth apart from blue plug behind fuse box

Share this post


Link to post
Share on other sites

that blue plug behind the fuse panel is a good place to get power but are you sure you got the right 1. there is 4 connections in that plug.

-power which has constant 12V

-power on with accessories 12V

-earth 0V

-mute 5V

as for which ones which, couldnt remember that's why a voltmeter is handy

Share this post


Link to post
Share on other sites

nah I got the right ones buddy ive done 4 stereos in ba's and bf's including twice on my own, this is the first time ive had problems with the plug not working though

Share this post


Link to post
Share on other sites

Do you have both power and acc hooked up yet or just the power and earth as I found with some HU's that you need both acc and power hooked up for it to turn on?

sounds simple but some miss this when they are testing. Also check both the fuse on the head unit and the fuses in the fuse box just incase. otherwise if all is good power wise its the earth or your deck is farked.

Also if you have a 12v power supply you could test it on there first to make sure it works?

Edited by bjc

Share this post


Link to post
Share on other sites

yeh I found my test light ill give it a crack tomorrow and try and work it out

had power earth and acc all hooked up, took head deck into JB today and they connected it to their jvc harness and it powered up so it isnt deck, I replaced the phone fuse which was blown and checked all other fuses including head unit all fine

so its in the wiring somewhere

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Donation Box

    Please donate to support the community.
    We appreciate all donations!


FordXR6Turbo.com Powered by Invision Community

×
×
  • Create New...