Jump to content


Sign in to follow this  
neoppg

Oil Pressure Guage In F6

Recommended Posts

ok..... need some help from F6 owners. where does your oil pressure guage sit....

1. at idle

2. normal driving

3. higher in the rev range.

I only ask because mine has all of a sudden started to run right off the guage and sits at over half way at idle and ford reckon I have nothing to be concerned about???????

cheers

Anthony

Edited by neoppg

Share this post


Link to post
Share on other sites

Did FORD recently service your car and use diff oil for engine oil.. I recently changed from 15-40 to 10-60 and my oil pressure has increased especially when cold.

Share this post


Link to post
Share on other sites

mine is a 2007 f6, it sits just above the first notch on idle, about quater on standard driving and just above half under hard throttle. bit higher on idle when cold. I would,nt worry to much if its stock?

Edited by Dagabond

Share this post


Link to post
Share on other sites

I have the gauges installed and its about 1/4 at idle half at cruising and full and flat stick... but I have been using different oils for the last few months and the gauge does sit differently too....

Share this post


Link to post
Share on other sites

you wouldn't belive it. car was booked in today to get the sender/guage looked at with ford. been running a ridiculous high oil pressure for 2-3 weeks and the minute I drove it in....... all working fine as it should be ......

will see what the outcome is tomorrow ?????

Share this post


Link to post
Share on other sites

look like your cars the same as mine.As soon as you drive in to a ford service department she sh*ts her bags.Like shes saying to us Please not FORD service. take me to anybody anytime anywear,But please not FORD. So if you have any probs with your car just drive in to a FORD service department & the problem will be gone.CHEERS BB

Share this post


Link to post
Share on other sites

something strange going on..... they told me that it looked like a sender problem and asked to keeep it 1 more night to rectify ..... but the next day, they claimed it was a faulty oil filter that was causing high ouil presssure???????? doesn't make sense to me but the oil pressure is back down to normal now....

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Donation Box

    Please donate to support the community.
    We appreciate all donations!


FordXR6Turbo.com Powered by Invision Community

×